UG NX2.0升级到NX2.0.2.6版本时提示:Incorrect machine type detected for this software.

Incorrect machine type detected for this software.

This software was originally intended for machine type: x86 

The hardware for this machine appears to be type: AID64

Please check that you are installing the right version of 

this software for your hardware.

If you are certain you wish to do this, you may override the hardwrare

check by setting an environment variable: REQUIRED_PLATFORI to the

value for your machine type (AID64) and re-run P:\UG2.0升级程序\ugs_update0206_02

\ugs_update0206_02\ugs_update0206\ugs_update.bat.

e.g.execute the following cornnand and re-run P:\UG2.0升级程序\ugs_update0206_02\ 

ugs_update0206_02\ugs_update0206\ugs_update.bat.

set REQUIRED_PLATFORM=AMD64

attachments-2019-09-WtmXBB5b5d7316cdd1671.png

请先 登录 后评论

1 个回答

老叶 - NX网、学技网、UG爱好者论坛创始人
擅长:NX软件

UG2.0是远古时代的版本了,所以和现在的WIN7\WIN10等版本不太兼容,所有有些电脑在升级NX2.0.2.6版本时可能会提示这个错误。

解决文案:

在升级包目录下看到,ugs_update.bat文件


attachments-2019-09-X0bMHOG55d7319476bbad.png

右键用记事本打开,在第二行(@echo off)加入:

set REQUIRED_PLATFORM=AMD64

attachments-2019-09-8jI5RWv35d73194de5e60.png

保存文件,再用右键-管理员身份打开ugs_update.bat文件,然后按任意键进行升级即可。

attachments-2019-09-HxEPPzYA5d731953ef258.png

(PS:如果升级不成功,建议重启电脑再试)

请先 登录 后评论